View Issue Details

IDProjectCategoryView StatusLast Update
0000102After The Collapse[All Projects] User Interfacepublic2018-11-28 23:45
ReporterJustinianAssigned ToEsKa 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
PlatformPCOSWindows 10OS VersionLatest
Product Version0.4.1 - Early Access 
Target VersionFixed in Version0.4.7 - Early Access 
Summary0000102: Clicking a storage box will disable some items
DescriptionI'll say that I'm not sure if this is on my end or others as well so I'll report it and hope for the best that it can be fixed.

When I click a storage box or any storage unit, it seems that it's like a double click happens almost. Meaning that one time I click the storage and everything is enabled. The next time I click it, it will disable something and those items will be kicked out. I say it seems like a double click is happening because it always seems to be one of the first few items listed, ie: armor, weapons, food.
Steps To Reproducebuild any storage item. Click on that item after its built.
TagsNo tags attached.

Activities

EsKa

2018-10-16 09:30

administrator   ~0000064

I can reproduce that by clicking on a container when it's placed where the menu should appear, the MouseDown event triggers the menu which, in turn, register the button release. If it happens to be on a checkbox, what you describe happens. (and in plenty of other cases for pretty much any menu).

It's tied to another problem you reported about items being clicked through some UI elements.
Granted i'm describing your problem accurately, while it seems like a small thing it's going a bit painful to fix properly no guarantee for 0.4.2

Issue History

Date Modified Username Field Change
2018-10-15 18:48 Justinian New Issue
2018-10-16 09:30 EsKa Note Added: 0000064
2018-10-16 09:30 EsKa Assigned To => EsKa
2018-10-16 09:30 EsKa Status new => assigned
2018-10-16 10:40 EsKa Category General => User Interface
2018-11-09 21:03 EsKa Status assigned => resolved
2018-11-09 21:03 EsKa Resolution open => fixed
2018-11-09 21:03 EsKa Fixed in Version => 0.4.7 - Early Access
2018-11-28 23:45 EsKa Status resolved => closed