View Issue Details

IDProjectCategoryView StatusLast Update
0000103After The Collapse[All Projects] Gameplaypublic2018-10-31 21:48
ReporterJustinianAssigned ToEsKa 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindows 10OS VersionLatest
Product Version0.4.1 - Early Access 
Target Version0.4.2 - Early AccessFixed in Version0.4.2 - Early Access 
Summary0000103: Starting Unlimited Points deletes wood and stone
DescriptionI've tried setting the unlimited starting points several times. It always removes the wood and stone so that you start with 0.
Steps To ReproduceSelect Unlimited Points; then click 10 rifles, 10 vests, 10 helmets, 10 of each seeds, then 500 stone/wood/metal/ceramic/coal/electronics.

Everything else will be there and only wood and stone will not be on your starting items. You can buy more, but it seems that the problem is coming from the rifles and vests and helmets. I will try to duplicate this with varying options to see where the problem starts.
TagsNo tags attached.

Relationships

has duplicate 0000112 closedEsKa Ticket 103 Still happening. 

Activities

EsKa

2018-10-16 09:31

administrator   ~0000065

Interesting (and... weird, like very weird) , i'll try replicating to see what happens. Probably nothing but out of the blue i don't see a reason for that behavior.

Justinian

2018-10-17 01:13

reporter   ~0000066

I've tried several things.
1. Tried with no weapons, vests, ammo, or helmets.. set wood and stone to 3000 each. They are still deleted upon new game.

2. Tried weapons, vests, ammo, helmets, wood, stone, metal, beer.. all under 300.. everything comes in just fine.

After more playing around.. I think the relationship here is the 1000 limit. Once you go over that it just doesn't recognize anything and therefore doesn't add it.

EsKa

2018-10-18 19:54

administrator   ~0000069

Ok, found the problem. The input box (where you put the number) is capped at 1000 units. So anything you add with a bigger number get set to 1000 instead. Adding 10x1000 stones does give out 10k stones. I'll change the cap.

Issue History

Date Modified Username Field Change
2018-10-15 19:03 Justinian New Issue
2018-10-16 09:31 EsKa Note Added: 0000065
2018-10-16 09:31 EsKa Assigned To => EsKa
2018-10-16 09:31 EsKa Status new => assigned
2018-10-17 01:13 Justinian Note Added: 0000066
2018-10-18 19:54 EsKa Note Added: 0000069
2018-10-18 19:54 EsKa Status assigned => resolved
2018-10-18 19:54 EsKa Resolution open => fixed
2018-10-18 19:54 EsKa Fixed in Version => 0.4.2 - Early Access
2018-10-18 19:54 EsKa Target Version => 0.4.2 - Early Access
2018-10-31 21:32 EsKa Status resolved => closed
2018-10-31 21:48 EsKa Relationship added has duplicate 0000112