View Issue Details

IDProjectCategoryView StatusLast Update
0000137After The Collapse[All Projects] Artificial Intelligencepublic2020-02-04 00:21
ReporterEsKaAssigned ToEsKa 
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
PlatformPC OSWindows 10OS VersionLatest (EsKa)
Product Version 
Target VersionFixed in Version 
Summary0000137: Crash on razejob
DescriptionSeems rare/random. see attached file

    <Message>Object reference not set to an instance of an object.</Message>

 AG.GameProject.ATC.Jobs.RazeJob.ExecuteJob(AGContainer pJobRunner)
   at AG.Components.JobManager.Update(Int32 gameTime)
   at AG.Components.AGContainer.Update(GameTime gameTime)
   at AG.Components.TiledAgent.Update(GameTime gameTime)
   at AG.GameProject.ATC.SRLAgent.Update(GameTime gameTime)
   at AG.GameProject.ATC.BodyAgent.Update(GameTime gameTime)
   at AG.GameProject.ATC.SRLScene.Update(GameTime gameTime)
Additional Informationlikely some data becoming null somewhere
TagsNo tags attached.

Activities

EsKa

2020-02-02 13:35

administrator  

Exception_132250988853626198.zip (597,655 bytes)

EsKa

2020-02-04 00:21

administrator   ~0000093

Hardened RazeJob() code. Found nothing particularly wrong with it, tho.
Will need a save (granted the bug survives savegames) if the problem persists.

Issue History

Date Modified Username Field Change
2020-02-02 13:35 EsKa New Issue
2020-02-02 13:35 EsKa Status new => assigned
2020-02-02 13:35 EsKa Assigned To => EsKa
2020-02-02 13:35 EsKa File Added: Exception_132250988853626198.zip
2020-02-02 13:35 EsKa Status assigned => acknowledged
2020-02-04 00:21 EsKa Status acknowledged => resolved
2020-02-04 00:21 EsKa Resolution open => unable to reproduce
2020-02-04 00:21 EsKa Note Added: 0000093